!!

Welcome to Selenium Webdriver Forum

As a web user you can read and search through forum content. Once you have registered and signed you can post topics, post replies, set up watch lists, modify forum settings, and use private messaging.

Author Topic: Selenium not able to find element in IE8 if view mode is Compatibility view  (Read 2398 times)

saorabh singh

  • Web User
Hi,
 I am using Selenium version 2.20
 Selenium not able to find element in IE if view mode is IE8 Compatibility
 view.
 is there any solution??
 
Regards,
 Saorabh Singh

saorabh singh

  • Web User
Hi,
 Any one has seen similar problem??
 please provide me the solution for this problem...
 I am not bale to run my tests on some Machine in IE8.
 
Regards,
 Saorabh Singh
 

- Show quoted text -

Jim Evans

  • Web User
You haven't provided any context for your question. You haven't said what
 API you're using (WebDriver or RC), you haven't said how you're trying to
 find your elements, and you haven't said what you've tried to mitigate the
 problem so far. I strongly suspect that the problem is related to
 differences in how IE constructs the DOM and uses JavaScript to interact
 with that DOM, but without more information, it's impossible to say.
 
--Jim
 

- Show quoted text -

Selenium Webdriver


saorabh singh

  • Web User
Well here are the details:
 i am using Selenium 2.20 Web driver,
 Same scripts works fine on Some IE browsers(IE8), So when i investigated
 more,
 I got the only difference between two Browsers is
 Browsers where scripts are working fine is working on Normal IE8 mode
 & other Browser where my scripts are getting failed is working on IE8
 Compatibility view.
 
OpenUrl function works fine in IE8 Compatibility view, Problem Starts only
 from Find element functionality.
 I am trying to find element by ID
 
These modes can be checked by pressing f12 & look for Browser mode.
 
Please let me know if i am missing some info.
 
Regards,
 Saorabh Singh
 

- Show quoted text -

Mike Riley

  • Web User
Have you set Zoom Level to 100%?
 
Have you set all Zones to the same level?
 
Those are common issues with IE.  You might have it set correctly for the
 other versions, but not this one.
 
Mike
 

- Show quoted text -

saorabh singh

  • Web User
I tried above steps mentioned by u...
 but still its not working
 
I am getting Exception:
 
org.openqa.selenium.NoSuchElementException: Unable to find element with
 name == username (WARNING: The server did not provide any stacktrace
 information); duration or timeout: 593 milliseconds
 For documentation on this error, please visit:
 _http://seleniumhq.org/exceptions/no_such_element.html
 Build info: version: '2.13.0', revision: '14793', time: '2011-11-18
 13:17:39'
 System info: os.name: 'Windows XP', os.arch: 'x86', os.version: '5.1',
 java.version: '1.6.0_20'
 Driver info: driver.version: RemoteWebDriver
 
Regards,
 Saorabh Singh
 

- Show quoted text -

Vijendra Aithal

  • Web User
What Mike has said should have solved the problem ...
 
I faced similar problem once , and found that for me IE worked only when I
 unchecked the protected mode ... strange
 
Go to IE Security Tab,
 For following zones
 - Internet,
 - Local internet,
 - Trusted sites and
 - Restricted sites
 
uncheck 'Enable Protected Mode' [Close all browsers and retry] ...
 
maybe you will get lucky
 
Regards
 Vijendra
 

- Show quoted text -

Mark Collin

  • Web User
Have you compared the DOM between IE8 in compatibility mode and IE8 in
 normal mode?
 
In compatibility mode it frigs about with the DOM in an attempt to emulate
 earlier IE behaviour (but doesn't quite match it).  I suspect that like Jim
 said the element is in a different place in the DOM in compatibility mode.
 
From: selenium-users@googlegroups.com
 [mailto:selenium-users@googlegroups.com] On Behalf Of saorabh singh
 Sent: 10 April 2012 11:41
 To: selenium-users@googlegroups.com
 Subject: [selenium-users] Re: Selenium not able to find element in IE8 if
 view mode is Compatibility view
 
Well here are the details:
 
i am using Selenium 2.20 Web driver,
 
Same scripts works fine on Some IE browsers(IE8), So when i investigated
 more,
 
I got the only difference between two Browsers is
 
Browsers where scripts are working fine is working on Normal IE8 mode
 
& other Browser where my scripts are getting failed is working on IE8
 Compatibility view.
 
OpenUrl function works fine in IE8 Compatibility view, Problem Starts only
 from Find element functionality.
 
I am trying to find element by ID
 
These modes can be checked by pressing f12 & look for Browser mode.
 
Please let me know if i am missing some info.
 
Regards,
 
Saorabh Singh
 

On Monday, 9 April 2012 19:16:07 UTC+5:30, Jim Evans wrote:
 

You haven't provided any context for your question. You haven't said what
 API you're using (WebDriver or RC), you haven't said how you're trying to
 find your elements, and you haven't said what you've tried to mitigate the
 problem so far. I strongly suspect that the problem is related to
 differences in how IE constructs the DOM and uses JavaScript to interact
 with that DOM, but without more information, it's impossible to say.
 --Jim
 

On Monday, April 9, 2012 1:36:10 AM UTC-4, saorabh singh wrote:
 

Hi,
 Any one has seen similar problem??
 
please provide me the solution for this problem...
 
I am not bale to run my tests on some Machine in IE8.
 
Regards,
 
Saorabh Singh
 

On Wednesday, 4 April 2012 18:08:56 UTC+5:30, saorabh singh wrote:
 

Hi,
 I am using Selenium version 2.20
 
Selenium not able to find element in IE if view mode is IE8 Compatibility
 view.
 
is there any solution??
 
Regards,
 
Saorabh Singh
 
--
 You received this message because you are subscribed to the Google Groups
 "Selenium Users" group.
 To view this discussion on the web visit
 https://groups.google.com/d/msg/selenium-users/-/1JDyRePwnqUJ.
 To post to this group, send email to selenium-users@googlegroups.com.
 To unsubscribe from this group, send email to
 selenium-users+unsubscribe@googlegroups.com.
 For more options, visit this group at
 http://groups.google.com/group/selenium-users?hl=en.

 

Related Topics

  Subject / Started by Replies Last post
14 Replies
3100 Views
Last post July 25, 2012, 10:26:22 PM
by Carrying_Smiles
4 Replies
869 Views
Last post February 21, 2012, 07:04:27 PM
by Nikki
7 Replies
1001 Views
Last post April 04, 2012, 04:24:11 PM
by Simon Stewart
7 Replies
1593 Views
Last post April 09, 2012, 04:55:02 PM
by Simon Stewart
1 Replies
473 Views
Last post May 03, 2012, 11:15:51 PM
by Ross Patterson
4 Replies
1730 Views
Last post July 24, 2012, 10:15:58 PM
by dlai
0 Replies
9 Views
Last post April 14, 2014, 02:40:16 PM
by LMJG