!!

Welcome to Selenium Webdriver Forum

As a web user you can read and search through forum content. Once you have registered and signed you can post topics, post replies, set up watch lists, modify forum settings, and use private messaging.

Author Topic: Internet explorer driver not working on rc2 candidate for .Net  (Read 1512 times)

tarun

  • Web User
Hi,
 I am using IE8, RC2 candidate on C#.
 For me IE driver is not launching.
 
Thanks
 Tarun

Nikhil Bhoski

  • Web User
Re: Internet explorer driver not working on rc2 candidate for .Net
« Reply #1 on: April 11, 2012, 03:14:21 PM »
Try adding ur test  URL in the list of trusted sites under tools and
 try again  it had solved similar problem for me though i am using java
 and not C# .
 
- Show quoted text -

Jim Evans

  • Web User
Re: Internet explorer driver not working on rc2 candidate for .Net
« Reply #2 on: April 11, 2012, 03:14:32 PM »
This is monumentally bad advice for RC2. Adding a site to the Trusted
 Sites zone hasn't been the appropriate way to solve problems with the
 IE driver since it was rewritten to use the JSON wire protocol.
 Additionally, there was a change between 2.0b3 and 2.0rc2 that will
 cause IE not to launch if your Protected Mode settings are not the
 same for all zones. Do you receive an error in your test code? If so,
 what error do you receive?
 Regards,
 --Jim
 
On Jun 6, 4:43 am, Nikhil Bhoski <nikhil.bho...@gmail.com> wrote:
 

- Show quoted text -

Selenium Webdriver

Re: Internet explorer driver not working on rc2 candidate for .Net
« Reply #2 on: April 11, 2012, 03:14:32 PM »

tarun

  • Web User
Re: Internet explorer driver not working on rc2 candidate for .Net
« Reply #3 on: April 11, 2012, 03:14:44 PM »
It got fixed after i made protected settings same on all the zones as
 u suggested.
 Thanks
 Tarun
 
On Jun 6, 3:30 pm, Jim Evans <james.h.evans...@gmail.com> wrote:
 

- Show quoted text -

poddarsumit

  • Web User
Re: Internet explorer driver not working on rc2 candidate for .Net
« Reply #4 on: April 11, 2012, 03:14:56 PM »
Hi
 Thanks.
 
It works for me too after setting the protected mode to be the same on
 all zones.
 However is this the way its always going to work or will there be a
 fix to make it behave as it used to in b3 where no separate
 configurations were needed to be made in the browser.
 
Cheers
 Sumit
 
On Jun 7, 12:51 am, tarun <tarun.tarunsha...@gmail.com> wrote:
 

- Show quoted text -

Jim Evans

  • Web User
Re: Internet explorer driver not working on rc2 candidate for .Net
« Reply #5 on: April 11, 2012, 03:15:09 PM »
Please note that this configuration has been a requirement since
 before 2.0b1. If you were running the IE driver without setting the
 Protected Mode settings, and it worked for you, then you were simply
 getting lucky, and there are no guarantees it will continue to work.
 Having said that, there has been exactly the change you're asking for,
 though I believe it was made after 2.0rc2. You can pass the
 ignoreProtectedModeSettings desired capability to get the pre-2.0rc2
 behavior. In C#, the code to do this would look like the following:
 DesiredCapabilities caps = DesiredCapabilities.InternetExplorer();
 caps.SetCapability("ignoreProtectedModeSettings", true);
 IWebDriver driver = new InternetExplorerDriver(caps);
 
--Jim
 
On Jun 12, 7:01 pm, poddarsumit <poddarsu...@gmail.com> wrote:
 

- Show quoted text -

sumit poddar

  • Web User
Re: Internet explorer driver not working on rc2 candidate for .Net
« Reply #6 on: April 11, 2012, 03:15:23 PM »
Thanks Jim. Tried it and it does not work so I am guessing its in the
 changes made after 2.0rc2.
 Regards
 Sumit
 
On Mon, Jun 13, 2011 at 1:35 PM, Jim Evans <james.h.evans...@gmail.com>wrote:
 

- Show quoted text -

 

Related Topics

  Subject / Started by Replies Last post
4 Replies
3311 Views
Last post February 21, 2012, 02:44:35 PM
by Ana Stavreva
1 Replies
1573 Views
Last post February 23, 2012, 01:46:38 PM
by Simon Stewart
13 Replies
3536 Views
Last post March 27, 2012, 08:33:43 PM
by Kevin Gann
4 Replies
1766 Views
Last post April 01, 2012, 09:04:32 PM
by James
1 Replies
974 Views
Last post April 02, 2012, 08:00:20 PM
by Mike
1 Replies
1577 Views
Last post April 09, 2012, 02:19:55 PM
by Sergii
10 Replies
1634 Views
Last post April 11, 2012, 10:59:27 PM
by Dylan Nicholson